What’s Vulnerable › Vulnerabilities
CVE-2023-4634: Media Library Assistant <= 3.09 - Unauthenticated Local/Remote File Inclusion & Remote Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 85.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-73
Description
The Media Library Assistant plugin for WordPress is vulnerable to Local File Inclusion and Remote Code Execution in versions up to, and including, 3.09. This is due to insufficient controls on file paths being supplied to the 'mla_stream_file' parameter from the ~/includes/mla-stream-image.php file, where images are processed via Imagick(). This makes it possible for unauthenticated attackers to supply files via FTP that will make directory lists, local file inclusion, and remote code execution possible.
Affected products
- dglingren Media Library Assistant: before 3.10 — fixed in 3.10
How to fix
Upgrade to a fixed version: dglingren Media Library Assistant 3.10. Check the vendor advisory for mitigations.
References
- https://github.com/Patrowl/CVE-2023-4634/
- https://packetstormsecurity.com/files/174508/wpmla309-lfiexec.tgz
- https://patrowl.io/blog-wordpress-media-library-rce-cve-2023-4634/
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2955933%40media-library-assistant&new=2955933%40media-library-assistant&sfp_email=&sfph_mail=#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/05c68377-feb6-442d-a3a0-1fbc246c7cbf?source=cve
- https://github.com/Patrowl/CVE-2023-4634/
- https://packetstormsecurity.com/files/174508/wpmla309-lfiexec.tgz
- https://patrowl.io/blog-wordpress-media-library-rce-cve-2023-4634/
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2955933%40media-library-assistant&new=2955933%40media-library-assistant&sfp_email=&sfph_mail=#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/05c68377-feb6-442d-a3a0-1fbc246c7cbf?source=cve
Get alerted when CVE-2023-4634 or the next vulnerability affects your stack