What’s Vulnerable › Vulnerabilities
CVE-2023-4643: Enable Media Replace < 4.1.3 - Author+ PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-16 · updated 2026-06-17
Description
The Enable Media Replace WordPress plugin before 4.1.3 unserializes user input via the Remove Background feature, which could allow Author+ users to perform PHP Object Injection when a suitable gadget is present on the blog
Affected products
- shortpixel Enable Media Replace: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: shortpixel Enable Media Replace 4.1.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d9125604-2236-435c-a67c-07951a1fc5b1
- https://wpscan.com/vulnerability/d9125604-2236-435c-a67c-07951a1fc5b1
Get alerted when CVE-2023-4643 or the next vulnerability affects your stack