What’s Vulnerable › Vulnerabilities
CVE-2023-46589: Apache Tomcat: HTTP request smuggling via malformed trailer headers
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-28 · updated 2026-06-17
- Weakness: CWE-444
Description
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.
Affected products
- Apache Tomcat: from 8.5.0 before 8.5.96; from 9.0.0 before 9.0.83; from 10.1.0 before 10.1.16; 11.0.0-milestone1, 11.0.0-milestone10, 11.0.0-milestone2, 11.0.0-milestone3, 11.0.0-milestone4, 11.0.0-milestone5 (+4) — fixed in 10.1.16, 8.5.96, 9.0.83
How to fix
Upgrade to a fixed version: Apache Tomcat 10.1.16, 8.5.96, 9.0.83. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/0rqq6ktozqc42ro8hhxdmmdjm1k1tpxr
- https://www.openwall.com/lists/oss-security/2023/11/28/2
- https://lists.apache.org/thread/0rqq6ktozqc42ro8hhxdmmdjm1k1tpxr
- https://lists.debian.org/debian-lts-announce/2024/01/msg00001.html
- https://security.netapp.com/advisory/ntap-20231214-0009/
- https://www.openwall.com/lists/oss-security/2023/11/28/2
Get alerted when CVE-2023-46589 or the next vulnerability affects your stack