What’s Vulnerable › Vulnerabilities
CVE-2023-46647: Improper Privilege Management in GitHub Enterprise Server management console leads to privilege escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-21 · updated 2026-06-17
- Weakness: CWE-269
Description
Improper privilege management in all versions of GitHub Enterprise Server allows users with authorized access to the management console with an editor role to escalate their privileges by making requests to the endpoint used for bootstrapping the instance. This vulnerability affected GitHub Enterprise Server version 3.8.0 and above and was fixed in version 3.8.12, 3.9.6, 3.10.3, and 3.11.0.
Affected products
- GitHub Enterprise Server: from 3.8.0 before 3.8.12; from 3.9.0 before 3.9.6; from 3.10.0 before 3.10.3 — fixed in 3.10.3, 3.8.12, 3.9.6
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.10.3, 3.8.12, 3.9.6. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.3
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.0
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.12
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.6
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.3
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.0
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.12
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.6
Get alerted when CVE-2023-46647 or the next vulnerability affects your stack