What’s Vulnerable › Vulnerabilities
CVE-2023-46718
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-14 · updated 2026-10-28
- Weakness: CWE-121
Description
A stack-based buffer overflow in Fortinet FortiOS version 7.4.0 through 7.4.1 and 7.2.0 through 7.2.7 and 7.0.0 through 7.0.12 and 6.4.6 through 6.4.15 and 6.2.9 through 6.2.16 and 6.0.13 through 6.0.18 allows attacker to execute unauthorized code or commands via specially crafted CLI commands.
Affected products
- Fortinet FortiOS (FortiGate): from 6.0.13 through 6.0.18; from 6.2.9 through 6.2.17; from 6.4.6 through 6.4.16; from 7.0.0 before 7.2.12; from 7.4.0 before 7.4.2 — fixed in 7.2.12, 7.4.2
- Fortinet FortiProxy: from 7.0.0 before 7.4.8 — fixed in 7.4.8
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.2.12, 7.4.2; Fortinet FortiProxy 7.4.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-46718 or the next vulnerability affects your stack