What’s Vulnerable › Vulnerabilities
CVE-2023-46726: GLPI Remote code execution from LDAP server configuration form on PHP 7.4
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-13 · updated 2026-06-17
- Weakness: CWE-74
Description
GLPI is a free asset and IT management software package. Starting in version 10.0.0 and prior to version 10.0.11, on PHP 7.4 only, the LDAP server configuration form can be used to execute arbitrary code previously uploaded as a GLPI document. Version 10.0.11 contains a patch for the issue.
Affected products
- glpi-project glpi: from 10.0.0 before 10.0.11 — fixed in 10.0.11
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.11. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/42ba2b031bec0b3889317db25f3adf9080fc11b2
- https://github.com/glpi-project/glpi/releases/tag/10.0.11
- https://github.com/glpi-project/glpi/security/advisories/GHSA-qc92-gxc6-5f95
- https://github.com/glpi-project/glpi/commit/42ba2b031bec0b3889317db25f3adf9080fc11b2
- https://github.com/glpi-project/glpi/releases/tag/10.0.11
- https://github.com/glpi-project/glpi/security/advisories/GHSA-qc92-gxc6-5f95
Get alerted when CVE-2023-46726 or the next vulnerability affects your stack