What’s Vulnerable › Vulnerabilities
CVE-2023-46727: GLPI SQL injection through inventory agent request
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 67.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-13 · updated 2026-06-17
- Weakness: CWE-89
Description
GLPI is a free asset and IT management software package. Starting in version 10.0.0 and prior to version 10.0.11, GLPI inventory endpoint can be used to drive a SQL injection attack. Version 10.0.11 contains a patch for the issue. As a workaround, disable native inventory.
Affected products
- glpi-project glpi: from 10.0.0 before 10.0.11 — fixed in 10.0.11
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.11. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/ee2d674481ebef177037e8e14d35c9455b5cfd46
- https://github.com/glpi-project/glpi/releases/tag/10.0.11
- https://github.com/glpi-project/glpi/security/advisories/GHSA-v799-2mp3-wgfr
- https://github.com/glpi-project/glpi/commit/ee2d674481ebef177037e8e14d35c9455b5cfd46
- https://github.com/glpi-project/glpi/releases/tag/10.0.11
- https://github.com/glpi-project/glpi/security/advisories/GHSA-v799-2mp3-wgfr
Get alerted when CVE-2023-46727 or the next vulnerability affects your stack