What’s Vulnerable › Vulnerabilities
CVE-2023-46729: Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-10 · updated 2026-06-17
- Weakness: CWE-918
Description
sentry-javascript provides Sentry SDKs for JavaScript. An unsanitized input of Next.js SDK tunnel endpoint allows sending HTTP requests to arbitrary URLs and reflecting the response back to the user. This issue only affects users who have Next.js SDK tunneling feature enabled. The problem has been fixed in version 7.77.0.
Affected products
- getsentry sentry-javascript: from 7.26.0 before 7.77.0 — fixed in 7.77.0
How to fix
Upgrade to a fixed version: getsentry sentry-javascript 7.77.0. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/sentry-javascript/commit/ddbda3c02c35aba8c5235e0cf07fc5bf656f81be
- https://github.com/getsentry/sentry-javascript/pull/9415
- https://github.com/getsentry/sentry-javascript/security/advisories/GHSA-2rmr-xw8m-22q9
- https://github.com/getsentry/sentry-javascript/commit/ddbda3c02c35aba8c5235e0cf07fc5bf656f81be
- https://github.com/getsentry/sentry-javascript/pull/9415
- https://github.com/getsentry/sentry-javascript/security/advisories/GHSA-2rmr-xw8m-22q9
Get alerted when CVE-2023-46729 or the next vulnerability affects your stack