What’s Vulnerable › Vulnerabilities
CVE-2023-46730: Server-Side Request Forgery in groupoffice
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-07 · updated 2026-06-17
- Weakness: CWE-918
Description
Group-Office is an enterprise CRM and groupware tool. In affected versions there is full Server-Side Request Forgery (SSRF) vulnerability in the /api/upload.php endpoint. The /api/upload.php endpoint does not filter URLs which allows a malicious user to cause the server to make resource requests to untrusted domains. Note that protocols like file:// can also be used to access the server disk. The request result (on success) can then be retrieved using /api/download.php. This issue has been addressed in versions 6.8.15, 6.7.54, and 6.6.177. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Intermesh groupoffice: from 6.3.1 before 6.6.177; from 6.7.0 before 6.7.54; from 6.8.0 before 6.8.15 — fixed in 6.6.177, 6.7.54, 6.8.15
How to fix
Upgrade to a fixed version: Intermesh groupoffice 6.6.177, 6.7.54, 6.8.15. Check the vendor advisory for mitigations.
References
- https://github.com/Intermesh/groupoffice/commit/99205535e8cec6592fd7f1469837926f27c72d50
- https://github.com/Intermesh/groupoffice/security/advisories/GHSA-vw6c-h82w-mvfv
- https://github.com/Intermesh/groupoffice/commit/99205535e8cec6592fd7f1469837926f27c72d50
- https://github.com/Intermesh/groupoffice/security/advisories/GHSA-vw6c-h82w-mvfv
Get alerted when CVE-2023-46730 or the next vulnerability affects your stack