What’s Vulnerable › Vulnerabilities

CVE-2023-46734: Symfony potential Cross-site Scripting vulnerabilities in CodeExtension filters

Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 2.0.0, 5.0.0, and 6.0.0 and prior to versions 4.4.51, 5.4.31, and 6.3.8, some Twig filters in CodeExtension use `is_safe=html` but don't actually ensure their input is safe. As of versions 4.4.51, 5.4.31, and 6.3.8, Symfony now escapes the output of the affected filters.

Affected products

How to fix

Upgrade to a fixed version: symfony 4.4.51, 5.4.31, 6.3.8; symfony Twig-Bridge 4.4.51, 5.4.31, 6.3.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-46734 or the next vulnerability affects your stack