What’s Vulnerable › Vulnerabilities
CVE-2023-46735: Symfony potential Cross-site Scripting in WebhookController
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in version 6.0.0 and prior to version 6.3.8, the error message in `WebhookController` returns unescaped user-submitted input. As of version 6.3.8, `WebhookController` now doesn't return any user-submitted input in its response.
Affected products
- symfony: from 6.0.0 before 6.3.8 — fixed in 6.3.8
How to fix
Upgrade to a fixed version: symfony 6.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/commit/8128c302430394f639e818a7103b3f6815d8d962
- https://github.com/symfony/symfony/security/advisories/GHSA-72x2-5c85-6wmr
- https://github.com/symfony/symfony/commit/8128c302430394f639e818a7103b3f6815d8d962
- https://github.com/symfony/symfony/security/advisories/GHSA-72x2-5c85-6wmr
Get alerted when CVE-2023-46735 or the next vulnerability affects your stack