What’s Vulnerable › Vulnerabilities
CVE-2023-46738: Authenticated users can crash the CubeFS servers with maliciously crafted requests
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-03 · updated 2026-06-17
- Weakness: CWE-770
Description
CubeFS is an open-source cloud-native file storage system. A security vulnerability was found in CubeFS HandlerNode in versions prior to 3.3.1 that could allow authenticated users to send maliciously-crafted requests that would crash the ObjectNode and deny other users from using it. The root cause was improper handling of incoming HTTP requests that could allow an attacker to control the ammount of memory that the ObjectNode would allocate. A malicious request could make the ObjectNode allocate more memory that the machine had available, and the attacker could exhaust memory by way of a single malicious request. An attacker would need to be authenticated in order to invoke the vulnerable code with their malicious request and have permissions to delete objects. In addition, the attacker would need to know the names of existing buckets of the CubeFS deployment - otherwise the request would be rejected before it reached the vulnerable code. As such, the most likely attacker is an inside user or an attacker that has breached the account of an existing user in the cluster. The issue has been patched in v3.3.1. There is no other mitigation besides upgrading.
Affected products
- cubefs: before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: cubefs 3.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/cubefs/cubefs/commit/dd46c24873c8f3df48d0a598b704ef9bd24b1ec1
- https://github.com/cubefs/cubefs/security/advisories/GHSA-qc6v-g3xw-grmx
- https://github.com/cubefs/cubefs/commit/dd46c24873c8f3df48d0a598b704ef9bd24b1ec1
- https://github.com/cubefs/cubefs/security/advisories/GHSA-qc6v-g3xw-grmx
Get alerted when CVE-2023-46738 or the next vulnerability affects your stack