What’s Vulnerable › Vulnerabilities
CVE-2023-46749: Apache Shiro before 1.13.0 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-15 · updated 2026-06-17
- Weakness: CWE-22
Description
Apache Shiro before 1.13.0 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting Mitigation: Update to Apache Shiro 1.13.0+ or 2.0.0-alpha-4+, or ensure `blockSemicolon` is enabled (this is the default).
Affected products
- Apache Software Foundation Apache Shiro: before 1.13.0; 2.0.0-alpha1, 2.0.0-alpha2, 2.0.0-alpha3 — fixed in 1.13.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Shiro 1.13.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/mdv7ftz7k4488rzloxo2fb0p9shnp9wm
- https://lists.apache.org/thread/mdv7ftz7k4488rzloxo2fb0p9shnp9wm
- https://security.netapp.com/advisory/ntap-20241108-0002/
Get alerted when CVE-2023-46749 or the next vulnerability affects your stack