What’s Vulnerable › Vulnerabilities
CVE-2023-4680: Vault's Transit Secrets Engine Allowed Nonce Specified without Convergent Encryption
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-323
Description
HashiCorp Vault and Vault Enterprise transit secrets engine allowed authorized users to specify arbitrary nonces, even with convergent encryption disabled. The encrypt endpoint, in combination with an offline attack, could be used to decrypt arbitrary ciphertext and potentially derive the authentication subkey when using transit secrets engine without convergent encryption. Introduced in 1.6.0 and fixed in 1.14.3, 1.13.7, and 1.12.11.
Affected products
- HashiCorp Vault: from 1.6.0 before 1.12.11; from 1.13.0 before 1.13.7; from 1.14.0 before 1.14.3 — fixed in 1.12.11, 1.13.7, 1.14.3
How to fix
Upgrade to a fixed version: HashiCorp Vault 1.12.11, 1.13.7, 1.14.3. Check the vendor advisory for mitigations.
References
- https://discuss.hashicorp.com/t/hcsec-2023-28-vault-s-transit-secrets-engine-allowed-nonce-specified-without-convergent-encryption/58249
- https://discuss.hashicorp.com/t/hcsec-2023-28-vault-s-transit-secrets-engine-allowed-nonce-specified-without-convergent-encryption/58249
Get alerted when CVE-2023-4680 or the next vulnerability affects your stack