What’s Vulnerable › Vulnerabilities
CVE-2023-46801: Apache Linkis DataSource: DataSource Remote code execution vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-15 · updated 2026-06-17
- Weakness: CWE-502
Description
In Apache Linkis <= 1.5.0, data source management module, when adding Mysql data source, exists remote code execution vulnerability for java version < 1.8.0_241. The deserialization vulnerability exploited through jrmp can inject malicious files into the server and execute them. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. We recommend that users upgrade the java version to >= 1.8.0_241. Or users upgrade Linkis to version 1.6.0.
Affected products
- Apache Software Foundation Apache Linkis: from 1.4.0 before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Linkis 1.6.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/0dnzh64xy1n7qo3rgo2loz9zn7m9xgdx
- http://www.openwall.com/lists/oss-security/2024/07/13/6
- https://lists.apache.org/thread/0dnzh64xy1n7qo3rgo2loz9zn7m9xgdx
Get alerted when CVE-2023-46801 or the next vulnerability affects your stack