What’s Vulnerable › Vulnerabilities
CVE-2023-46818
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-27 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue was discovered in ISPConfig before 3.2.11p1. PHP code injection can be achieved in the language file editor by an admin if admin_allow_langedit is enabled.
Affected products
- ISPConfig: before 3.2.11; 3.2.11 — fixed in 3.2.11
How to fix
Upgrade to a fixed version: ISPConfig 3.2.11. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/176126/ISPConfig-3.2.11-PHP-Code-Injection.html
- http://seclists.org/fulldisclosure/2023/Dec/2
- https://www.ispconfig.org/blog/ispconfig-3-2-11p1-released/
- http://packetstormsecurity.com/files/176126/ISPConfig-3.2.11-PHP-Code-Injection.html
- http://seclists.org/fulldisclosure/2023/Dec/2
- https://www.ispconfig.org/blog/ispconfig-3-2-11p1-released/
Get alerted when CVE-2023-46818 or the next vulnerability affects your stack