What’s Vulnerable › Vulnerabilities
CVE-2023-4682: Heap-based Buffer Overflow in gpac/gpac
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-31 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.
Affected products
- GPAC: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: GPAC 2.3. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/b1042c3eefca87c4bc32afb404ed6518d693e5be
- https://huntr.dev/bounties/15232a74-e3b8-43f0-ae8a-4e89d56c474c
- https://github.com/gpac/gpac/commit/b1042c3eefca87c4bc32afb404ed6518d693e5be
- https://huntr.dev/bounties/15232a74-e3b8-43f0-ae8a-4e89d56c474c
Get alerted when CVE-2023-4682 or the next vulnerability affects your stack