What’s Vulnerable › Vulnerabilities
CVE-2023-46845
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-07 · updated 2026-06-17
- Weakness: CWE-94
Description
EC-CUBE 3 series (3.0.0 to 3.0.18-p6) and 4 series (4.0.0 to 4.0.6-p3, 4.1.0 to 4.1.2-p2, and 4.2.0 to 4.2.2) contain an arbitrary code execution vulnerability due to improper settings of the template engine Twig included in the product. As a result, arbitrary code may be executed on the server where the product is running by a user with an administrative privilege.
Affected products
- EC-CUBE CO.,LTD. EC-CUBE: from 3.0.0 through 3.0.18; from 4.0.0 through 4.0.6; from 4.1.0 through 4.1.2; from 4.2.0 before 4.2.3; 3.0.18-p1, 3.0.18-p2, 3.0.18-p3, 3.0.18-p4, 3.0.18-p5, 3.0.18-p6 (+5) — fixed in 4.2.3
How to fix
Upgrade to a fixed version: EC-CUBE CO.,LTD. EC-CUBE 4.2.3. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN29195731/
- https://www.ec-cube.net/info/weakness/20231026/index.php
- https://www.ec-cube.net/info/weakness/20231026/index_3.php
- https://www.ec-cube.net/info/weakness/20231026/index_40.php
- https://jvn.jp/en/jp/JVN29195731/
- https://www.ec-cube.net/info/weakness/20231026/index.php
- https://www.ec-cube.net/info/weakness/20231026/index_3.php
- https://www.ec-cube.net/info/weakness/20231026/index_40.php
Get alerted when CVE-2023-46845 or the next vulnerability affects your stack