What’s Vulnerable › Vulnerabilities
CVE-2023-46848: Squid: denial of service in ftp
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-03 · updated 2026-06-17
- Weakness: CWE-681
Description
Squid is vulnerable to Denial of Service, where a remote attacker can perform DoS by sending ftp:// URLs in HTTP Request messages or constructing ftp:// URLs from FTP Native input.
Affected products
- Red Hat Enterprise Linux: 9.0
- RedHat Enterprise Linux Eus: 9.2
- RedHat Enterprise Linux Server Aus: 9.2
- RedHat Enterprise Linux Server Tus: 9.2
- Squid: from 5.0.3 before 6.4 — fixed in 6.4
How to fix
Upgrade to a fixed version: Squid 6.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2023:6266
- https://access.redhat.com/errata/RHSA-2023:6268
- https://access.redhat.com/errata/RHSA-2023:6748
- https://access.redhat.com/security/cve/CVE-2023-46848
- https://bugzilla.redhat.com/show_bug.cgi?id=2245919
- https://github.com/squid-cache/squid/security/advisories/GHSA-2g3c-pg7q-g59w
- https://access.redhat.com/errata/RHSA-2023:6266
- https://access.redhat.com/errata/RHSA-2023:6268
- https://access.redhat.com/errata/RHSA-2023:6748
- https://access.redhat.com/security/cve/CVE-2023-46848
- https://bugzilla.redhat.com/show_bug.cgi?id=2245919
- https://github.com/squid-cache/squid/security/advisories/GHSA-2g3c-pg7q-g59w
Get alerted when CVE-2023-46848 or the next vulnerability affects your stack