What’s Vulnerable › Vulnerabilities
CVE-2023-46850
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-11 · updated 2026-06-23
- Weakness: CWE-416
Description
Use after free in OpenVPN version 2.6.0 to 2.6.6 may lead to undefined behavoir, leaking memory buffers or remote execution when sending network buffers to a remote peer.
Affected products
- Debian Linux: 12.0
- Fedoraproject Fedora: 39
- OpenVPN: from 2.6.0 through 2.6.6
- OpenVPN Access Server: from 2.11.0 through 2.11.3; from 2.12.0 before 2.12.2 — fixed in 2.12.2
How to fix
Upgrade to a fixed version: OpenVPN Access Server 2.12.2. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/openvpn/wiki/CVE-2023-46850
- https://openvpn.net/security-advisory/access-server-security-update-cve-2023-46849-cve-2023-46850/
- https://community.openvpn.net/openvpn/wiki/CVE-2023-46850
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/L3FS46ANNTAVLIQY56ZKGM5CBTRVBUNE/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/O54I7D753V6PU6XBU26FEROD2DSHEJQ4/
- https://openvpn.net/security-advisory/access-server-security-update-cve-2023-46849-cve-2023-46850/
- https://www.debian.org/security/2023/dsa-5555
Get alerted when CVE-2023-46850 or the next vulnerability affects your stack