What’s Vulnerable › Vulnerabilities
CVE-2023-46851: Apache Allura: sensitive information exposure via import
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-07 · updated 2026-06-17
- Weakness: CWE-20
Description
Allura Discussion and Allura Forum importing does not restrict URL values specified in attachments. Project administrators can run these imports, which could cause Allura to read local files and expose them. Exposing internal files then can lead to other exploits, like session hijacking, or remote code execution. This issue affects Apache Allura from 1.0.1 through 1.15.0. Users are recommended to upgrade to version 1.16.0, which fixes the issue. If you are unable to upgrade, set "disable_entry_points.allura.importers = forge-tracker, forge-discussion" in your .ini config file.
Affected products
- Apache Software Foundation Apache Allura: from 1.0.1 before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Allura 1.16.0. Check the vendor advisory for mitigations.
References
- https://allura.apache.org/posts/2023-allura-1.16.0.html
- https://lists.apache.org/thread/hqk0vltl7qgrq215zgwjfoj0khbov0gx
- https://allura.apache.org/posts/2023-allura-1.16.0.html
- https://lists.apache.org/thread/hqk0vltl7qgrq215zgwjfoj0khbov0gx
Get alerted when CVE-2023-46851 or the next vulnerability affects your stack