What’s Vulnerable › Vulnerabilities
CVE-2023-46853
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-27 · updated 2026-06-17
- Weakness: CWE-193
Description
In Memcached before 1.6.22, an off-by-one error exists when processing proxy requests in proxy mode, if \n is used instead of \r\n.
Affected products
- Memcached: before 1.6.22 — fixed in 1.6.22
How to fix
Upgrade to a fixed version: Memcached 1.6.22. Check the vendor advisory for mitigations.
References
- https://github.com/memcached/memcached/commit/6987918e9a3094ec4fc8976f01f769f624d790fa
- https://github.com/memcached/memcached/compare/1.6.21...1.6.22
- https://github.com/memcached/memcached/commit/6987918e9a3094ec4fc8976f01f769f624d790fa
- https://github.com/memcached/memcached/compare/1.6.21...1.6.22
Get alerted when CVE-2023-46853 or the next vulnerability affects your stack