What’s Vulnerable › Vulnerabilities
CVE-2023-46854
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Proxmox proxmox-widget-toolkit before 4.0.9, as used in multiple Proxmox products, allows XSS via the edit notes feature.
Affected products
- Proxmox-Widget-Toolkit: before 4.0.9 — fixed in 4.0.9
How to fix
Upgrade to a fixed version: Proxmox-Widget-Toolkit 4.0.9. Check the vendor advisory for mitigations.
References
- https://git.proxmox.com/?p=proxmox-widget-toolkit.git%3Ba=commit%3Bh=1326f771b959e576d140da2249c8b5424da6c80d
- https://git.proxmox.com/?p=proxmox-widget-toolkit.git%3Ba=commit%3Bh=89699c6466cfd9cc3a81fbc926b62f122c33c23c
- https://pve.proxmox.com/wiki/Package_Repositories#sysadmin_test_repo
- https://git.proxmox.com/?p=proxmox-widget-toolkit.git%3Ba=commit%3Bh=1326f771b959e576d140da2249c8b5424da6c80d
- https://git.proxmox.com/?p=proxmox-widget-toolkit.git%3Ba=commit%3Bh=89699c6466cfd9cc3a81fbc926b62f122c33c23c
- https://pve.proxmox.com/wiki/Package_Repositories#sysadmin_test_repo
Get alerted when CVE-2023-46854 or the next vulnerability affects your stack