What’s Vulnerable › Vulnerabilities

CVE-2023-4700: Missing Authorization in GitLab

Description

An authorization issue affecting GitLab EE affecting all versions from 14.7 prior to 16.3.6, 16.4 prior to 16.4.2, and 16.5 prior to 16.5.1, allowed a user to run jobs in protected environments, bypassing any required approvals.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.3.6, 16.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-4700 or the next vulnerability affects your stack