What’s Vulnerable › Vulnerabilities

CVE-2023-47090

Description

NATS nats-server before 2.9.23 and 2.10.x before 2.10.2 has an authentication bypass. An implicit $G user in an authorization block can sometimes be used for unauthenticated access, even when the intention of the configuration was for each user to have an account. The earliest affected version is 2.2.0.

Affected products

How to fix

Upgrade to a fixed version: nats-io nats-server 2.10.2, 2.9.23. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-47090 or the next vulnerability affects your stack