What’s Vulnerable › Vulnerabilities
CVE-2023-47119: HTML injection in oneboxed links
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-10 · updated 2026-06-17
- Weakness: CWE-74
Description
Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, some links can inject arbitrary HTML tags when rendered through our Onebox engine. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
- discourse: before 3.1.3; before 3.2.0; 3.2.0-beta1, 3.2.0-beta2 — fixed in 3.1.3, 3.2.0
How to fix
Upgrade to a fixed version: discourse 3.1.3, 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/628b293ff53fb617b3464dd27268aec84388cc09
- https://github.com/discourse/discourse/commit/d78357917c6a917a8a27af68756228e89c69321c
- https://github.com/discourse/discourse/security/advisories/GHSA-j95w-5hvx-jp5w
- https://github.com/discourse/discourse/commit/628b293ff53fb617b3464dd27268aec84388cc09
- https://github.com/discourse/discourse/commit/d78357917c6a917a8a27af68756228e89c69321c
- https://github.com/discourse/discourse/security/advisories/GHSA-j95w-5hvx-jp5w
Get alerted when CVE-2023-47119 or the next vulnerability affects your stack