What’s Vulnerable › Vulnerabilities
CVE-2023-47121: Discourse SSRF vulnerability in Embedding
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-10 · updated 2026-06-17
- Weakness: CWE-918
Description
Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the embedding feature is susceptible to server side request forgery. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable the Embedding feature.
Affected products
- discourse: before 3.1.3; before 3.2.0; 3.2.0-beta1, 3.2.0-beta2 — fixed in 3.1.3, 3.2.0
How to fix
Upgrade to a fixed version: discourse 3.1.3, 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/24cca10da731734af4e9748de99a508d586e59f1
- https://github.com/discourse/discourse/commit/5f20748e402223b265e6fee381472c14e2604da6
- https://github.com/discourse/discourse/security/advisories/GHSA-hp24-94qf-8cgc
- https://github.com/discourse/discourse/commit/24cca10da731734af4e9748de99a508d586e59f1
- https://github.com/discourse/discourse/commit/5f20748e402223b265e6fee381472c14e2604da6
- https://github.com/discourse/discourse/security/advisories/GHSA-hp24-94qf-8cgc
Get alerted when CVE-2023-47121 or the next vulnerability affects your stack