What’s Vulnerable › Vulnerabilities
CVE-2023-47130: Unsafe deserialization of user data in yiisoft/yii
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-14 · updated 2026-06-17
- Weakness: CWE-502
Description
Yii is an open source PHP web framework. yiisoft/yii before version 1.1.29 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. An attacker may leverage this vulnerability to compromise the host system. A fix has been developed for the 1.1.29 release. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- yiisoft yii: before 1.1.29 — fixed in 1.1.29
How to fix
Upgrade to a fixed version: yiisoft yii 1.1.29. Check the vendor advisory for mitigations.
References
- https://github.com/yiisoft/yii/commit/37142be4dc5831114a375392e86d6450d4951c06
- https://github.com/yiisoft/yii/security/advisories/GHSA-mw2w-2hj2-fg8q
- https://owasp.org/www-community/vulnerabilities/PHP_Object_Injection
- https://github.com/yiisoft/yii/commit/37142be4dc5831114a375392e86d6450d4951c06
- https://github.com/yiisoft/yii/security/advisories/GHSA-mw2w-2hj2-fg8q
- https://owasp.org/www-community/vulnerabilities/PHP_Object_Injection
Get alerted when CVE-2023-47130 or the next vulnerability affects your stack