What’s Vulnerable › Vulnerabilities
CVE-2023-4720: Floating Point Comparison with Incorrect Operator in gpac/gpac
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-01 · updated 2026-06-17
- Weakness: CWE-1077
Description
Floating Point Comparison with Incorrect Operator in GitHub repository gpac/gpac prior to 2.3-DEV.
Affected products
- GPAC: before 2.3-dev — fixed in 2.3-dev
How to fix
Upgrade to a fixed version: GPAC 2.3-dev. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/e396648e48c57e2d53988d3fd4465b068b96c89a
- https://huntr.dev/bounties/1dc2954c-8497-49fa-b2af-113e1e9381ad
- https://github.com/gpac/gpac/commit/e396648e48c57e2d53988d3fd4465b068b96c89a
- https://huntr.dev/bounties/1dc2954c-8497-49fa-b2af-113e1e9381ad
Get alerted when CVE-2023-4720 or the next vulnerability affects your stack