What’s Vulnerable › Vulnerabilities
CVE-2023-47308
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-15 · updated 2026-06-17
- Weakness: CWE-89
Description
In the module "Newsletter Popup PRO with Voucher/Coupon code" (newsletterpop) before version 2.6.1 from Active Design for PrestaShop, a guest can perform SQL injection in affected versions. The method `NewsletterpopsendVerificationModuleFrontController::checkEmailSubscription()` has sensitive SQL calls that can be executed with a trivial http call and exploited to forge a SQL injection.
Affected products
- Activedesign Newsletterpop: from 2.3.1 through 2.4.53; from 2.5.2 before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: Activedesign Newsletterpop 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/friends-of-presta/security-advisories/blob/main/_posts/2023-11-09-newsletterpop.md
- https://github.com/friends-of-presta/security-advisories/blob/main/_posts/2023-11-09-newsletterpop.md
Get alerted when CVE-2023-47308 or the next vulnerability affects your stack