What’s Vulnerable › Vulnerabilities
CVE-2023-4734: Integer Overflow or Wraparound in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-02 · updated 2026-09-18
- Weakness: CWE-190
Description
Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.1846.
Affected products
- Apple macOS: before 14.1 — fixed in 14.1
- Neovim: from 0.7.0 before 0.10.0 — fixed in 0.10.0
- vim/vim: before 9.0.1846 — fixed in 9.0.1846
How to fix
Upgrade to a fixed version: Apple macOS 14.1; Neovim 0.10.0; vim/vim 9.0.1846. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Oct/24
- https://github.com/vim/vim/commit/4c6fe2e2ea62469642ed1d80b16d39e616b25cf5
- https://huntr.dev/bounties/688e4382-d2b6-439a-a54e-484780f82217
- https://support.apple.com/kb/HT213984
- http://seclists.org/fulldisclosure/2023/Oct/24
- https://github.com/vim/vim/commit/4c6fe2e2ea62469642ed1d80b16d39e616b25cf5
- https://huntr.dev/bounties/688e4382-d2b6-439a-a54e-484780f82217
- https://support.apple.com/kb/HT213984
Get alerted when CVE-2023-4734 or the next vulnerability affects your stack