What’s Vulnerable › Vulnerabilities
CVE-2023-47350
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-22 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in SwiftyEdit Content Management System prior to v1.2.0, allows remote attackers to escalate privileges via the user password update functionality.
Affected products
- Swiftyedit: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Swiftyedit 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/SwiftyEdit/SwiftyEdit/commit/90a6f3df16cd1578b2827d7b2e073451f7ce4e47
- https://mechaneus.github.io/CVE-2023-47350.html
- https://github.com/SwiftyEdit/SwiftyEdit/commit/90a6f3df16cd1578b2827d7b2e073451f7ce4e47
- https://mechaneus.github.io/CVE-2023-47350.html
Get alerted when CVE-2023-47350 or the next vulnerability affects your stack