What’s Vulnerable › Vulnerabilities
CVE-2023-47359
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-07 · updated 2026-06-17
- Weakness: CWE-787
Description
Videolan VLC prior to version 3.0.20 contains an incorrect offset read that leads to a Heap-Based Buffer Overflow in function GetPacket() and results in a memory corruption.
Affected products
- VideoLAN VLC: before 3.0.20 — fixed in 3.0.20
How to fix
Upgrade to a fixed version: VideoLAN VLC 3.0.20. Check the vendor advisory for mitigations.
References
- https://0xariana.github.io/blog/real_bugs/vlc/mms
- https://lists.debian.org/debian-lts-announce/2023/11/msg00034.html
- https://0xariana.github.io/blog/real_bugs/vlc/mms
- https://lists.debian.org/debian-lts-announce/2023/11/msg00034.html
Get alerted when CVE-2023-47359 or the next vulnerability affects your stack