What’s Vulnerable › Vulnerabilities
CVE-2023-4738: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-02 · updated 2026-09-18
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1848.
Affected products
- Apple macOS: 14.0
- Debian Linux: 11.0
- Neovim: before 0.10.0 — fixed in 0.10.0
- vim/vim: before 9.0.1848 — fixed in 9.0.1848
How to fix
Upgrade to a fixed version: Neovim 0.10.0; vim/vim 9.0.1848. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Oct/24
- https://github.com/vim/vim/commit/ced2c7394aafdc90fb7845e09b3a3fee23d48cb1
- https://huntr.dev/bounties/9fc7dced-a7bb-4479-9718-f956df20f612
- https://support.apple.com/kb/HT213984
- http://seclists.org/fulldisclosure/2023/Oct/24
- https://github.com/vim/vim/commit/ced2c7394aafdc90fb7845e09b3a3fee23d48cb1
- https://huntr.dev/bounties/9fc7dced-a7bb-4479-9718-f956df20f612
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://support.apple.com/kb/HT213984
Get alerted when CVE-2023-4738 or the next vulnerability affects your stack