What’s Vulnerable › Vulnerabilities
CVE-2023-47440
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-07 · updated 2026-06-17
- Weakness: CWE-22
Description
Gladys Assistant v4.27.0 and prior is vulnerable to Directory Traversal. The patch of CVE-2023-43256 was found to be incomplete, allowing authenticated attackers to extract sensitive files in the host machine.
Affected products
- Gladysassistant Gladys Assistant: before 4.30.0 — fixed in 4.30.0
How to fix
Upgrade to a fixed version: Gladysassistant Gladys Assistant 4.30.0. Check the vendor advisory for mitigations.
References
- https://blog.moku.fr/cve/
- https://blog.moku.fr/cves/CVE-2023-47440/
- https://github.com/GladysAssistant/Gladys/pull/1918/commits/4f56ba250ff9f46578f1afa6a97e62e74bad83b7
- https://blog.moku.fr/cve/
- https://blog.moku.fr/cves/CVE-2023-47440/
- https://github.com/GladysAssistant/Gladys/pull/1918/commits/4f56ba250ff9f46578f1afa6a97e62e74bad83b7
Get alerted when CVE-2023-47440 or the next vulnerability affects your stack