What’s Vulnerable › Vulnerabilities
CVE-2023-47480
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-20 · updated 2026-06-17
- Weakness: CWE-252
Description
An issue in Pure Data 0.54-0 and fixed in 0.54-1 allows a local attacker to escalate privileges via the set*id () function.
Affected products
- Puredata: from 0.54-0 before 0.54-1 — fixed in 0.54-1
How to fix
Upgrade to a fixed version: Puredata 0.54-1. Check the vendor advisory for mitigations.
References
- https://github.com/pure-data/pure-data/commit/0b5e467b8728b3ed56e1a8ee5b367ce78e7e6e5d
- https://github.com/pure-data/pure-data/issues/2063
- https://puredata.info/
- https://lists.debian.org/debian-lts-announce/2024/09/msg00038.html
Get alerted when CVE-2023-47480 or the next vulnerability affects your stack