What’s Vulnerable › Vulnerabilities
CVE-2023-4751: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-03 · updated 2026-09-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1331.
Affected products
- Apple macOS: 14.0
- Neovim: before 0.9.0 — fixed in 0.9.0
- vim/vim: before 9.0.1331 — fixed in 9.0.1331
How to fix
Upgrade to a fixed version: Neovim 0.9.0; vim/vim 9.0.1331. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Oct/24
- https://github.com/vim/vim/commit/e1121b139480f53d1b06f84f3e4574048108fa0b
- https://huntr.dev/bounties/db7be8d6-6cb7-4ae5-9c4e-805423afa378
- https://support.apple.com/kb/HT213984
- http://seclists.org/fulldisclosure/2023/Oct/24
- https://github.com/vim/vim/commit/e1121b139480f53d1b06f84f3e4574048108fa0b
- https://huntr.dev/bounties/db7be8d6-6cb7-4ae5-9c4e-805423afa378
- https://support.apple.com/kb/HT213984
Get alerted when CVE-2023-4751 or the next vulnerability affects your stack