What’s Vulnerable › Vulnerabilities
CVE-2023-4756: Stack-based Buffer Overflow in gpac/gpac
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-04 · updated 2026-06-17
- Weakness: CWE-121
Description
Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.
Affected products
- GPAC: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: GPAC 2.3. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/6914d016e2b540bac2c471c4aea156ddef8e8e01
- https://huntr.dev/bounties/2342da0e-f097-4ce7-bfdc-3ec0ba446e05
- https://github.com/gpac/gpac/commit/6914d016e2b540bac2c471c4aea156ddef8e8e01
- https://huntr.dev/bounties/2342da0e-f097-4ce7-bfdc-3ec0ba446e05
Get alerted when CVE-2023-4756 or the next vulnerability affects your stack