What’s Vulnerable › Vulnerabilities
CVE-2023-4758: Buffer Over-read in gpac/gpac
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-04 · updated 2026-06-17
- Weakness: CWE-126
Description
Buffer Over-read in GitHub repository gpac/gpac prior to 2.3-DEV.
Affected products
- GPAC: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: GPAC 2.3. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/193633b1648582444fc99776cd741d7ba0125e86
- https://huntr.dev/bounties/2f496261-1090-45ac-bc89-cc93c82090d6
- https://github.com/gpac/gpac/commit/193633b1648582444fc99776cd741d7ba0125e86
- https://huntr.dev/bounties/2f496261-1090-45ac-bc89-cc93c82090d6
Get alerted when CVE-2023-4758 or the next vulnerability affects your stack