What’s Vulnerable › Vulnerabilities
CVE-2023-47635: Decidim vulnerable to possible CSRF attack at questionnaire templates preview
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-918
Description
Decidim is a participatory democracy framework. Starting in version 0.23.0 and prior to versions 0.27.5 and 0.28.0, the CSRF authenticity token check is disabled for the questionnaire templates preview. The issue does not imply a serious security thread as you need to have access also to the session cookie in order to see this resource. This URL does not allow modifying the resource but it may allow attackers to gain access to information which was not meant to be public. The issue is fixed in version 0.27.5 and 0.28.0. As a workaround, disable the templates functionality or remove all available templates.
Affected products
- decidim: from 0.23.0 before 0.27.5 — fixed in 0.27.5
How to fix
Upgrade to a fixed version: decidim 0.27.5. Check the vendor advisory for mitigations.
References
- https://github.com/decidim/decidim/blob/3187bdfd40ea1c57c2c12512b09a7fec0b2bed08/decidim-templates/app/controllers/decidim/templates/admin/questionnaire_templates_controller.rb#L11
- https://github.com/decidim/decidim/commit/5542227be66e3b6d7530f5b536069bce09376660
- https://github.com/decidim/decidim/commit/57a4b467787448307b5d9b01ce6e2c8502e121ac
- https://github.com/decidim/decidim/pull/11743
- https://github.com/decidim/decidim/pull/6247
- https://github.com/decidim/decidim/releases/tag/v0.27.5
- https://github.com/decidim/decidim/releases/tag/v0.28.0
- https://github.com/decidim/decidim/security/advisories/GHSA-f3qm-vfc3-jg6v
- https://github.com/decidim/decidim/blob/3187bdfd40ea1c57c2c12512b09a7fec0b2bed08/decidim-templates/app/controllers/decidim/templates/admin/questionnaire_templates_controller.rb#L11
- https://github.com/decidim/decidim/commit/5542227be66e3b6d7530f5b536069bce09376660
- https://github.com/decidim/decidim/commit/57a4b467787448307b5d9b01ce6e2c8502e121ac
- https://github.com/decidim/decidim/pull/11743
Get alerted when CVE-2023-47635 or the next vulnerability affects your stack