What’s Vulnerable › Vulnerabilities
CVE-2023-47637: SQL Injection in Admin Grid Filter API in Pimcore
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-15 · updated 2026-06-17
- Weakness: CWE-89
Description
Pimcore is an Open Source Data & Experience Management Platform. In affected versions the `/admin/object/grid-proxy` endpoint calls `getFilterCondition()` on fields of classes to be filtered for, passing input from the request, and later executes the returned SQL. One implementation of `getFilterCondition()` is in `Multiselect`, which does not normalize/escape/validate the passed value. Any backend user with very basic permissions can execute arbitrary SQL statements and thus alter any data or escalate their privileges to at least admin level. This vulnerability has been addressed in version 11.1.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- pimcore/pimcore: before 11.1.1 — fixed in 11.1.1
How to fix
Upgrade to a fixed version: pimcore/pimcore 11.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/admin-ui-classic-bundle/blob/bba7c7419cb1f06d5fd98781eab4d6995e4e5dca/src/Helper/GridHelperService.php#L311
- https://github.com/pimcore/pimcore/commit/d164d99c90f098d0ccd6b72929c48b727e2953a0
- https://github.com/pimcore/pimcore/security/advisories/GHSA-72hh-xf79-429p
- https://github.com/pimcore/admin-ui-classic-bundle/blob/bba7c7419cb1f06d5fd98781eab4d6995e4e5dca/src/Helper/GridHelperService.php#L311
- https://github.com/pimcore/pimcore/commit/d164d99c90f098d0ccd6b72929c48b727e2953a0
- https://github.com/pimcore/pimcore/security/advisories/GHSA-72hh-xf79-429p
Get alerted when CVE-2023-47637 or the next vulnerability affects your stack