What’s Vulnerable › Vulnerabilities
CVE-2023-4776: WPSchoolPress < 2.2.5 - Teacher+ SQLi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-89
Description
The School Management System WordPress plugin before 2.2.5 uses the WordPress esc_sql() function on a field not delimited by quotes and did not first prepare the query, leading to a SQL injection exploitable by relatively low-privilege users like Teachers.
Affected products
- jdsofttech School Management System – WPSchoolPress: before 2.2.5 — fixed in 2.2.5
How to fix
Upgrade to a fixed version: jdsofttech School Management System – WPSchoolPress 2.2.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/59dd3917-01cb-479f-a557-021b2a5147df
- https://wpscan.com/vulnerability/59dd3917-01cb-479f-a557-021b2a5147df
Get alerted when CVE-2023-4776 or the next vulnerability affects your stack