What’s Vulnerable › Vulnerabilities
CVE-2023-4781: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-05 · updated 2026-09-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1873.
Affected products
- Apple macOS: before 14.1 — fixed in 14.1
- Debian Linux: 10.0, 11.0
- Neovim: through 0.9.5
- vim/vim: before 9.0.1873 — fixed in 9.0.1873
How to fix
Upgrade to a fixed version: Apple macOS 14.1; vim/vim 9.0.1873. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Oct/24
- https://github.com/vim/vim/commit/f6d28fe2c95c678cc3202cc5dc825a3fcc709e93
- https://huntr.dev/bounties/c867eb0a-aa8b-4946-a621-510350673883
- https://lists.debian.org/debian-lts-announce/2023/09/msg00035.html
- https://support.apple.com/kb/HT213984
- http://seclists.org/fulldisclosure/2023/Oct/24
- https://github.com/vim/vim/commit/f6d28fe2c95c678cc3202cc5dc825a3fcc709e93
- https://huntr.dev/bounties/c867eb0a-aa8b-4946-a621-510350673883
- https://lists.debian.org/debian-lts-announce/2023/09/msg00035.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://support.apple.com/kb/HT213984
Get alerted when CVE-2023-4781 or the next vulnerability affects your stack