What’s Vulnerable › Vulnerabilities
CVE-2023-4785: Denial of Service in gRPC Core
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-13 · updated 2026-06-17
- Weakness: CWE-248
Description
Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. Linux) allows an attacker to cause a denial of service by initiating a significant number of connections with the server. Note that gRPC C++ Python, and Ruby are affected, but gRPC Java, and Go are NOT affected.
Affected products
- Google gRPC: from 1.23.0 before 1.53.2; from 1.54.0 before 1.54.3; from 1.55.0 before 1.55.3; 1.56.0 — fixed in 1.53.2, 1.54.3, 1.55.3
How to fix
Upgrade to a fixed version: Google gRPC 1.53.2, 1.54.3, 1.55.3. Check the vendor advisory for mitigations.
References
- https://github.com/grpc/grpc/pull/33656
- https://github.com/grpc/grpc/pull/33667
- https://github.com/grpc/grpc/pull/33669
- https://github.com/grpc/grpc/pull/33670
- https://github.com/grpc/grpc/pull/33672
- https://github.com/grpc/grpc/pull/33656
- https://github.com/grpc/grpc/pull/33667
- https://github.com/grpc/grpc/pull/33669
- https://github.com/grpc/grpc/pull/33670
- https://github.com/grpc/grpc/pull/33672
Get alerted when CVE-2023-4785 or the next vulnerability affects your stack