What’s Vulnerable › Vulnerabilities

CVE-2023-4812: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 15.3 before 16.5.6, all versions starting from 16.6 before 16.6.4, all versions starting from 16.7 before 16.7.2. The required CODEOWNERS approval could be bypassed by adding changes to a previously approved merge request.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.5.5, 16.6.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-4812 or the next vulnerability affects your stack