What’s Vulnerable › Vulnerabilities
CVE-2023-48218: Strapi Protected Populate Plugin leaking fields if the request fields where empty or only fields selected where not populatable
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-20 · updated 2026-06-17
- Weakness: CWE-863
Description
The Strapi Protected Populate Plugin protects `get` endpoints from revealing too much information. Prior to version 1.3.4, users were able to bypass the field level security. Users who tried to populate something that they didn't have access to could populate those fields anyway. This issue has been patched in version 1.3.4. There are no known workarounds.
Affected products
- strapi-community strapi-plugin-protected-populate: before 1.3.4 — fixed in 1.3.4
How to fix
Upgrade to a fixed version: strapi-community strapi-plugin-protected-populate 1.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/strapi-community/strapi-plugin-protected-populate/commit/05441066d64e09dd55937d9f089962e9ebe2fb39
- https://github.com/strapi-community/strapi-plugin-protected-populate/releases/tag/v1.3.4
- https://github.com/strapi-community/strapi-plugin-protected-populate/security/advisories/GHSA-6h67-934r-82g7
- https://github.com/strapi-community/strapi-plugin-protected-populate/commit/05441066d64e09dd55937d9f089962e9ebe2fb39
- https://github.com/strapi-community/strapi-plugin-protected-populate/releases/tag/v1.3.4
- https://github.com/strapi-community/strapi-plugin-protected-populate/security/advisories/GHSA-6h67-934r-82g7
Get alerted when CVE-2023-48218 or the next vulnerability affects your stack