What’s Vulnerable › Vulnerabilities
CVE-2023-48219: Special characters in unescaped text nodes can trigger mXSS in TinyMCE
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
TinyMCE is an open source rich text editor. A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo/redo functionality and other APIs and plugins. Text nodes within specific parents are not escaped upon serialization according to the HTML standard. If such text nodes contain a special character reserved as an internal marker, they can be combined with other HTML patterns to form malicious snippets. These snippets pass the initial sanitisation layer when the content is parsed into the editor body, but can trigger XSS when the special internal marker is removed from the content and re-parsed. his vulnerability has been patched in TinyMCE versions 6.7.3 and 5.10.9. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- tinymce: before 5.10.9; from 6.0.0 before 6.7.3 — fixed in 5.10.9, 6.7.3
How to fix
Upgrade to a fixed version: tinymce 5.10.9, 6.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/tinymce/tinymce/security/advisories/GHSA-v626-r774-j7f8
- https://tiny.cloud/docs/release-notes/release-notes5109/
- https://tiny.cloud/docs/tinymce/6/6.7.3-release-notes/
- https://github.com/tinymce/tinymce/security/advisories/GHSA-v626-r774-j7f8
- https://tiny.cloud/docs/release-notes/release-notes5109/
- https://tiny.cloud/docs/tinymce/6/6.7.3-release-notes/
Get alerted when CVE-2023-48219 or the next vulnerability affects your stack