What’s Vulnerable › Vulnerabilities
CVE-2023-48221: wire-avs remote format string vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-20 · updated 2026-06-17
- Weakness: CWE-134
Description
wire-avs provides Audio, Visual, and Signaling (AVS) functionality sure the secure messaging software Wire. Prior to versions 9.2.22 and 9.3.5, a remote format string vulnerability could potentially allow an attacker to cause a denial of service or possibly execute arbitrary code. The issue has been fixed in wire-avs 9.2.22 & 9.3.5 and is already included on all Wire products. No known workarounds are available.
Affected products
- Wire Audio, Video, And Signaling: before 9.2.22; from 9.3.0 through 9.3.5 — fixed in 9.2.22
How to fix
Upgrade to a fixed version: Wire Audio, Video, And Signaling 9.2.22. Check the vendor advisory for mitigations.
References
- https://github.com/wireapp/wire-avs/commit/364c3326a1331a84607bce2e17126306d39150cd
- https://github.com/wireapp/wire-avs/security/advisories/GHSA-m4xg-fcr3-w3pq
- https://github.com/wireapp/wire-avs/commit/364c3326a1331a84607bce2e17126306d39150cd
- https://github.com/wireapp/wire-avs/security/advisories/GHSA-m4xg-fcr3-w3pq
Get alerted when CVE-2023-48221 or the next vulnerability affects your stack