What’s Vulnerable › Vulnerabilities
CVE-2023-48231: Use-After-Free in win_close() in vim
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-16 · updated 2026-06-23
- Weakness: CWE-416
Description
Vim is an open source command line text editor. When closing a window, vim may try to access already freed window structure. Exploitation beyond crashing the application has not been shown to be viable. This issue has been addressed in commit `25aabc2b` which has been included in release version 9.0.2106. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Fedoraproject Fedora: 37, 38, 39
- vim/vim: before 9.0.2106 — fixed in 9.0.2106
How to fix
Upgrade to a fixed version: vim/vim 9.0.2106. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/16/1
- https://github.com/vim/vim/commit/25aabc2b8ee1e19ced6f4da9d866cf9378fc4c5a
- https://github.com/vim/vim/security/advisories/GHSA-8g46-v9ff-c765
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4UJAK2W5S7G75ETDAEM3BDUCVSXCEGRD/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/M3VQF7CL3V6FGSEW37WNDFBRRILR65AK/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VNRNYLWXZOGTYWE5HMFNQ5FVE3HBUHF6/
- https://security.netapp.com/advisory/ntap-20231227-0008/
- http://www.openwall.com/lists/oss-security/2023/11/16/1
- https://github.com/vim/vim/commit/25aabc2b8ee1e19ced6f4da9d866cf9378fc4c5a
- https://github.com/vim/vim/security/advisories/GHSA-8g46-v9ff-c765
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4UJAK2W5S7G75ETDAEM3BDUCVSXCEGRD/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/M3VQF7CL3V6FGSEW37WNDFBRRILR65AK/
Get alerted when CVE-2023-48231 or the next vulnerability affects your stack