What’s Vulnerable › Vulnerabilities
CVE-2023-48236: overflow in get_number in vim
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-16 · updated 2026-06-23
- Weakness: CWE-190
Description
Vim is an open source command line text editor. When using the z= command, the user may overflow the count with values larger than MAX_INT. Impact is low, user interaction is required and a crash may not even happen in all situations. This vulnerability has been addressed in commit `73b2d379` which has been included in release version 9.0.2111. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Fedoraproject Fedora: 37, 38, 39
- vim/vim: before 9.0.2111 — fixed in 9.0.2111
How to fix
Upgrade to a fixed version: vim/vim 9.0.2111. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/16/1
- https://github.com/vim/vim/commit/73b2d3790cad5694fc0ed0db2926e4220c48d968
- https://github.com/vim/vim/security/advisories/GHSA-pr4c-932v-8hx5
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4UJAK2W5S7G75ETDAEM3BDUCVSXCEGRD/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/M3VQF7CL3V6FGSEW37WNDFBRRILR65AK/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VNRNYLWXZOGTYWE5HMFNQ5FVE3HBUHF6/
- https://security.netapp.com/advisory/ntap-20231227-0002/
- http://www.openwall.com/lists/oss-security/2023/11/16/1
- https://github.com/vim/vim/commit/73b2d3790cad5694fc0ed0db2926e4220c48d968
- https://github.com/vim/vim/security/advisories/GHSA-pr4c-932v-8hx5
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4UJAK2W5S7G75ETDAEM3BDUCVSXCEGRD/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/M3VQF7CL3V6FGSEW37WNDFBRRILR65AK/
Get alerted when CVE-2023-48236 or the next vulnerability affects your stack